ThinkPad 600E へ Puppy Linux インストール(断念?)

Windows98 がリカバリーされていた ThinkPad 600E ですが、いつものように軽量 Linux の雄の Puppy Linux をインストールしてみました。正確には CD ブートで動作確認した後、インストールを中止しました。

ThinkPad 600E には CD ドライブが内蔵されているため、Puppy Linux などの 1CD Linux の起動が気楽に行えるようになっています。

Puppy Linux 4.3.1 (2012) の CD から起動させてみました。すると ThinkPad 570 でも見られた起動不良となってしまいました。

Searching deeper, sub-sub-folders in partitions…pup-431.sfs not found. Dropping out initial-ramdisk console…

ThinkPad 570 の起動不良のときには、起動オプションに acpi=force を付け加えると起動しました。今回の ThinkPad 600E でも試してみました。

Puppy linux 4.3.1 (2012) の起動メニューで e キーを押して GRUB の編集メニューへ入ります。そして kernel の行にカーソルを合わせて再度 e キーを押してコマンドを編集して acpi=force を追加します。英語キーボードのキー配置となっているため = キーは隣の ^ キーで入力できます。acpi=force を追加したところでリターンキーを押して編集を確定します。そして b キーを押してブートさせます。

やはり acpi=force で正解だったようで ThinkPad 600E 上で Puppy Linux 4.3.1 (2012) は起動してくれました。

xorg で 800×600 で起動しましたので、1024x768x24 へ切り替えました。

起動したところで、ネットワークカードを認識していないようであったので、ネットワーク・ウィザードで設定することとしました。するとネットワークカードを認識していませんでした。いろいろカードを交換してみましたが、カード上の LED ランプ類も点灯しない状況でした。内蔵されている CardBus チップは TI 社製の PCI1251A というものでした。今までに出会ったことのなかったチップでした。TI 社製の CardBus チップと Puppy Linux は相性が悪いようなので、今回も相性の悪さなのでしょうか?なお PC カードスロットへメモリカードなども差し込んでみましたが、全く認識しませんでした。Windows98 上では認識していたため PC カードスロットや CardBus のチップには問題はないものと思われます。

念のため Puppy Linux 5.2.8 においても acpi=force のオプションを付加して起動させて PC カードの様子を確認してみましたが同様に PC カードを一切認識しませんでした。

他の Linux でも PC カードが利用できないのか確認してみました。DSL 4.4 を使ってみましたが、起動と同時に PC カードスロットに挿入されたネットワークカードを認識していました。やはり Puppy Linux の問題のようです。その他 knoppix 6.7 でも起動させてみましたが、PC カードを利用できました。

どうも ThinkPad 600E で Puppy Linux を利用するのは得策ではないようです。

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト /  変更 )

Google フォト

Google アカウントを使ってコメントしています。 ログアウト /  変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト /  変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト /  変更 )

%s と連携中